SPSS-Datensatz laden

Allgemeine Fragen zur Programmierung mit R.

SPSS-Datensatz laden

Beitragvon denitsa91 » Mo 1. Aug 2016, 18:52

Hallo zusammen,
ich habe bei R foglendes Problem. Ich kann den SPSS-Datensatz nicht laden, da es immer wieder Fehlermeldung (Warning message: In read.spss("C:\\Users\\Deni\\Documents\\Studium\\KoWi\\4. Semester - MA\\Umfrage\\Pretest Daten\\Pretest.sav", : C:\Users\Deni\Documents\Studium\KoWi\4. Semester - MA\Umfrage\Pretest Daten\Pretest.sav: Unrecognized record type 7, subtype 18 encountered in system file) kommt... Könnte mir jemand sagen, was an meinem Code falsch ist:

install.packages("foreign", dependencies = TRUE)
library(foreign)
dataset = read.spss("C:\\Users\\Deni\\Documents\\Studium\\KoWi\\4. Semester - MA\\Umfrage\\Pretest Daten\\Pretest.sav", to.data.frame=TRUE)

Das ist der kopierte Pfad vom File Explorer: C:\Users\Deni\Documents\Studium\KoWi\4. Semester - MA\Umfrage\Pretest Daten
merci und LG Deni
denitsa91
 
Beiträge: 4
Registriert: Fr 11. Mär 2016, 13:37
Danke gegeben: 0
Danke bekommen: 0 mal in 0 Post

Re: SPSS-Datensatz laden

Beitragvon lilchaos » Di 2. Aug 2016, 08:51

Hey,

In dem Warning stehen jeweils 2 backslashes, ich vermute R fügt escape sequenzen ein da du statt backslash einen normalen slash benutzen musst. Also in dem kopierten Pfad einfach die Slashes ändern.

Lg
lilchaos
 
Beiträge: 50
Registriert: Mi 22. Jun 2016, 20:11
Danke gegeben: 0
Danke bekommen: 0 mal in 0 Post

Re: SPSS-Datensatz laden

Beitragvon denitsa91 » Di 2. Aug 2016, 09:59

Hey, danke für deine Antwort! Ich habe es auch mit dem / ausprobiert. Kommt auch Fehler....
Es ist mir noch aufgefallen, dass beim Laden des foreign-Pakets eine Fehlermeldung kommt "Error in .requirePackage(package) : unable to find required package ‘lavaan’" aber dann steht zum Schluss erfolgreich runtergeladen, kann es daran liegen?
denitsa91
 
Beiträge: 4
Registriert: Fr 11. Mär 2016, 13:37
Danke gegeben: 0
Danke bekommen: 0 mal in 0 Post

Re: SPSS-Datensatz laden

Beitragvon lilchaos » Di 2. Aug 2016, 10:21

Hey,

den Fehler hatte ich auch schon...aber ich muss gestehen ich bin nichtmehr sicher wie ich das gemacht habe. Hast du mal probiert lavaan explizit zu installieren und zu laden? Sieht so aus als bräuchte er das package, findet es aber auch irgendeinem grund nicht. (Ich bin kein R pro das sind nur dinge die ich selbst ausprobieren würde ;) also keine Garantie ^^)

edit: was auch ab und an probleme machen kann sind die sonderzeichen in datei/Ordnernamen du hast einen ordner mit einem bindestrich und einem punkt auch das kann ab und an ein problem werden ;)

lg
lilchaos
 
Beiträge: 50
Registriert: Mi 22. Jun 2016, 20:11
Danke gegeben: 0
Danke bekommen: 0 mal in 0 Post

Re: SPSS-Datensatz laden

Beitragvon denitsa91 » Di 2. Aug 2016, 10:51

Hey,
mit names() sehe ich jetzt doch meinen Datensatz, also dann hat es jetzt doch geladen oder wie :D bloß diese Fehlermeldungen...
denitsa91
 
Beiträge: 4
Registriert: Fr 11. Mär 2016, 13:37
Danke gegeben: 0
Danke bekommen: 0 mal in 0 Post

Re: SPSS-Datensatz laden

Beitragvon lilchaos » Di 2. Aug 2016, 13:13

Hey,

hmm seltsam...schau dir aber den datensatz nochmal an bevor du damit arbeitest ob nicht evtl doch fehler beim einladen gemacht wurden.

lg
lilchaos
 
Beiträge: 50
Registriert: Mi 22. Jun 2016, 20:11
Danke gegeben: 0
Danke bekommen: 0 mal in 0 Post

Re: SPSS-Datensatz laden

Beitragvon Fried » Di 11. Dez 2018, 01:53

Hallo zusammen,

ich habe dasselbe Problem. "lavaan" wird nicht gefunden, obwohl ich es hierüber heruntergeladen habe: https://cran.r-project.org/web/packages/lavaan/
Es gibt dort allerdings keine exe...

Ich möchte SPSSLAVAAN als Erweiterungsbundle in SPSS installieren, aber es kommt immer, dass lavaan nicht gefunden werden konnte. (R ist auch in allen möglichen Versionen installiert...)

Danke!!
Fried
 
Beiträge: 3
Registriert: Di 13. Nov 2018, 19:46
Danke gegeben: 0
Danke bekommen: 0 mal in 0 Post


Zurück zu Programmierung allgemein

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron